I used the topology above to practice many protocols but this is highly recommended for layer 2 protocols such as:
- 802.1q (trunking)
- Etherchannels (LACP and PAGP)
- RSTP (Rapid Spanning-tree)
The creation of Etherchannels is very important in order to avoid the wastage of bandwidth between the switches with more than one link. Also, there isn’t any waste of time with STP while trying to bring the interface up.
Switch1# configure terminal
Switch1(config)# interface range G0/0-1
Switch1(config-if)# channel-group 5 mode active
Switch2# configure terminal
Switch2(config)# interface range G0/0-1
Switch2(config-if)# channel-group 5 mode active
Switch1#configure terminal
Switch1(config)#interface port-channel 5
Switch1(config-if)# switchport mode trunk
Switch2#configure terminal
Switch2(config)#interface port-channel 5
Switch2(config-if)# switchport mode trunk